Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8264862

JavaFX build uses deprecated features that will be removed in gradle 7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: openjfx17
    • Fix Version/s: None
    • Component/s: javafx
    • Labels:

      Description

      The JavaFX gradle build scripts use deprecated features that will be removed in gradle 7. We need to replace them in our current build.gradle before we can consider updating to gradle 7 (see JDK-8263760), which in turn blocks updating our boot JDK to JDK 16 (see JDK-8263761).

      To reproduce this, run:

      $ gradle --info --warning-mode all all

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kcr Kevin Rushforth
              Reporter:
              kcr Kevin Rushforth
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: