Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8265031

Change default macOS min version for x86_64 to 10.12 and aarch64 to 11.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: openjfx17
    • Fix Version/s: openjfx17
    • Component/s: javafx
    • Labels:

      Description

      The minimum macOS version on which JavaFX will run is currently set to 10.10:

      https://github.com/openjdk/jfx/blob/8adbc673d095607e8a6109fbb951fa17b9d6caad/buildSrc/mac.gradle#L58

      defineProperty("MACOSX_MIN_VERSION", "10.10");

      macOS 10.10 is many years out of support, so we should update this minimum. Further, macOS / aarch64 (aka arm64) requires macOS 11.0 as a minimum in order to run.

      The JDK recently updated their minimum for x86_64 to 10.12 and for aarch64 to 11.0. See:

      https://github.com/openjdk/jdk/blob/627ad9fe22a153410c14d0b2061bb7dee2c300af/make/autoconf/flags.m4#L136

      We should do the same for JavaFX.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kcr Kevin Rushforth
              Reporter:
              kcr Kevin Rushforth
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: