Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8266554

Change default macOS min version for aarch64 to 11.0

    XMLWordPrintable

    Details

    • Subcomponent:
    • OS:
      os_x

      Backports

        Description

        The minimum macOS version on which JavaFX will run is currently set to 10.10:

        https://github.com/openjdk/jfx11u/blob/debbd07dfe122f550e6770cfe34b4bf1e7eaff05/buildSrc/mac.gradle#L54

        defineProperty("MACOSX_MIN_VERSION", "10.10");

        macOS / aarch64 (aka arm64) requires macOS 11.0 as a minimum in order to run.

        NOTE: This issue was cloned from JDK-8265031. Rather than backport that issue to FX 11 and FX 8 in its entirety, we will only update the minimum macOS version for aarch64 builds (to 11.0). For compatibility reasons, we will leave the default macOS version at 10.10 for the older releases of JavaFX.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                jvos Johan Vos
                Reporter:
                kcr Kevin Rushforth
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: