Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8267485

Remove the dependency on SecurityManager in JceSecurityManager.java

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 18
    • Component/s: security-libs
    • Labels:

      Description

      JceSecurityManager is a subclass of SecurityManager in order to get the class context and eventually the classes to determine if any required signing of providers or crypto permissions overriding of applications is necessary.

      JEP 411 proposes to deprecate the SecurityManager for removal. If JEP 411 is approved, we will need to eventually remove the dependency "extends SecurityManager".

      The class stack hierarchy can be obtained using the newer JDK 9 API StackWalker. Once the class is obtained, the CodeBase/ProtectionDomain jar verifications can proceed as before.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              wetmore Bradford Wetmore
              Reporter:
              wetmore Bradford Wetmore
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: