Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8268349

Provide clear run-time warnings about Security Manager deprecation

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 17
    • Fix Version/s: 17
    • Component/s: security-libs
    • Labels:
      None

      Backports

        Description

        In connection with JEP 411, provide clear warnings when a Security Manager is enabled at startup or installed at run time. If a command line option prevents a Security Manager from being installed at run time, provide a clear message in the UnsupportedOperationException thrown by System::setSecurityManager.

        See the CSR for further details.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mullan Sean Mullan
                Reporter:
                mullan Sean Mullan
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: