Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8268611

jar --validate should check targeted classes in MR-JAR files

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: New
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: tools
    • Labels:
      None
    • Subcomponent:
      jar
    • CPU:
      generic
    • OS:
      generic

      Description

      All targeted classes in a MR-JAR file should target the same or at least a lower bytecode level. For example, META-INF/versions/9 must not contain .class files targeting Java 10 or higher.

      The --validate option introduced into the jar tool since Java 17 seems a good place to check this constraint.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cstein Christian Stein
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: