Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8271466

[jdk8u] StackGap test fails on aarch64 due to "-m64"

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b01
    • CPU:
      other
    • OS:
      linux

      Description

      This is on behalf of <xiangyuan@tencent.com>.

      3 tests fail on aarch64 platform.
       
      1. hotspot/test/runtime/StackGap/testme.sh
      Error Info: gcc: error: unrecognized command line option '-m64'
      When compiling stack-gap, this case passes compiler option '-m64' to gcc, which is unrecoginized by gcc on aarch64.
       
      2. jdk/test/sun/management/jmxremote/bootstrap/CustomLauncherTest.java
      Error Info: [jdk/test/sun/management/jmxremote/bootstrap/linux-aarch64/launcher] does not exist. Skipping the test
       
      This testcase depends on a pre-built binary launcher, which is placed the directory "jdk/test/sun/management/jmxremote/bootstrap/{OS-arch}/launcher".
      Now there isn't include the file "linux-aarch64/launcher".
       
      3. jdk/test/sun/security/pkcs11/Secmod/TestNssDbSqlite.java
      Error Info: Unsupported OS, skipping: Linux-aarch64-64
       
      File jdk/test/sun/security/pkcs11/PKCS11Test.java defines a hashmap named osMap to help to find some native libs on different platform, which doesn't include aarch64.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              andrew Andrew Hughes
              Reporter:
              jiefu Jie Fu
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: