Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8273774

CDSPluginTest should only expect classes_nocoops.jsa exists on supported 64-bit platforms

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 18
    • Fix Version/s: 18
    • Component/s: tools
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b16

      Description

      Filed on behalf of Sun Xu (sunxu01@loongson.cn).

      The test assumes that it always runs on 64-bit platform and classes_nocoops.jsa is always created.
      It's a test bug. The test should only expect classes_nocoops.jsa exists if it's running on a supported 64-bit platform.
      However, for unknown target platform, it's unknown if it's 64-bit or not.

      This patch fix the test to check if classes_nocoops.jsa exists only on one of the JDK supported platforms (x64 or aarch64) via the sun.arch.data.model system property.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ccheung Calvin Cheung
              Reporter:
              aoqi Qi Ao
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: