Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8275506

Rename allocated_on_stack to allocated_on_stack_or_embedded

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 18
    • Fix Version/s: 18
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b23

      Description

      In allocation.hpp, the name allocated_on_stack can be misleading, better rename the function to allocated_on_stack_or_embedded and it will match the name of the enum as a bonus.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              lkorinth Leo Korinth
              Reporter:
              lkorinth Leo Korinth
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: