Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8276093

Improve naming in closures to iterate over card sets

    XMLWordPrintable

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b25

      Description

      Naming in closures used for `G1CardSet::iterate_for_merge` is a bit of a mess, using "Iterator" and "Closure" interchangably. That is confusing to readers.

      Try to improve here.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tschatzl Thomas Schatzl
              Reporter:
              tschatzl Thomas Schatzl
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: