Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8276472

align_metadata_size is a nop

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 18
    • Fix Version/s: 19
    • Component/s: hotspot
    • Labels:

      Description

      align_metadata_size(x) returns align_up(x, 1), which is a complicated (and probably constant-folded) way to write 'x'.

      JDK-8145628 introduced align_metadata_size with that definition. Since the size is argument in supposed to be in words, it seems correct. But the definition could be simplified. The assumption that the size is words should also be mentioned. Or maybe it should be moved elsewhere and changed to use the WordSize class

        Attachments

          Activity

            People

            Assignee:
            coleenp Coleen Phillimore
            Reporter:
            kbarrett Kim Barrett
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: