Uploaded image for project: 'Java Mission Control'
  1. Java Mission Control
  2. JMC-6513

Wrong version of compiled classes when importing JMC maven projects in Eclipse with JDT Default Compiler Level of 11

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 7.1.0
    • Fix Version/s: 7.1.0
    • Component/s: Infrastructure
    • Labels:
      None
    • Subcomponent:
    • Sprint:
      JMC 7.1 Sprint 3

      Description

      When importing the JMC (maven) projects into Eclipse JDT as per http://hirt.se/blog/?p=989 and the default compiler compliance level is 11 (Probably anything higher than 8), several projects are compiled with the higher compiler level and hence a launch configuration for Java 8 would not work.

        Attachments

          Activity

            People

            • Assignee:
              clanger Christoph Langer
              Reporter:
              clanger Christoph Langer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: