Uploaded image for project: 'Java Mission Control'
  1. Java Mission Control
  2. JMC-7118

After upgrading the platform to 4.19, use -Dorg.eclipse.swt.browser.DefaultType=edge on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: P2
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 8.1.0
    • Component/s: Release Engineering
    • Labels:
      None

      Description

      We should, if possible, remove the special chromium browser plug-in, and simply use the SWTbrowser with -Dorg.eclipse.swt.browser.DefaultType=edge.

      We will have to release note that the WebView2 distribution will have to be installed, until it ships with Windows:
      https://docs.microsoft.com/en-us/microsoft-edge/webview2/concepts/distribution

      This should make it possible for us to ditch one non-eclipse update site (the one from which get the chromium binaries), and we'd no longer need to have a dependency on the chromium fragment.

      Of course, we'll have to ensure that it all works. The effect will be that the Flame View and Graph View will not work on pre 4.19 platforms on Windows. On the other hand they will now hopefully both work on 4.19 based builds.

        Attachments

          Activity

            People

            Assignee:
            ghb Guru Hb
            Reporter:
            hirt Marcus Hirt
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: