Uploaded image for project: 'Skara'
  1. Skara
  2. SKARA-716

Git version check pattern matching is too strict

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9
    • Component/s: cli
    • Labels:
      None

      Description

      Running on a machine with an older git (in my case, 2.7.0) results in:

      $ git sync
      WARNING: Your git version is: UNKNOWN, which is not a known supported version.

      This is not about accepting or rejecting versions, just about that the version string is not parsed correctly and hence the output is confusing.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              stuefe Thomas Stuefe
              Reporter:
              stuefe Thomas Stuefe
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: