Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8080588 VarHandles development
  3. JDK-8162108

Rename weakCompareAndSetVolatile to weakCompareAndSet

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:

      Description

      Rename weakCompareAndSet to weakCompareAndSetPlain and weakCompareAndSetVolatile to weakCompareAndSet, thereby leveraging a consistent naming scheme for read-modify-write methods.

      The Atomic* classes should be updated in a separate issue to:

      1) deprecate (not for removal) weakCompareAndSet
      2) add weakCompareAndSetPlain, and leave weakCompareAndSetVolatile (which remains the sole inconsistency in the naming scheme)

        Attachments

          Activity

            People

            Assignee:
            psandoz Paul Sandoz
            Reporter:
            psandoz Paul Sandoz
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: