Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8187667

Disable deprecation warning for readdir_r

    Details

    • Subcomponent:
    • Resolved In Build:
      b31

      Backports

        Description

        The function readdir_r has been deprecated in glibc since version 2.24 (see https://sourceware.org/bugzilla/show_bug.cgi?id=19056). Since hotspot wants to be compatible with glibc both older and newer than 2.24, the easiest thing for now is to ignore the warning.

        Later, if readdir_r actually gets removed in a future version of glibc, then we might have to fall back to e.g. dlopen to check if readdir_r is present. However, as long as readdir_r is "just" deprecated, then it easier to just disable the warning from gcc.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  ehelin Erik Helin
                  Reporter:
                  ehelin Erik Helin
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: